[LSI MegaRaid] Webbios startet nicht

Achtung: führen Sie die Schritte dieser Anleitung nicht durch, falls bereits eine RAID-Konfiguration vorhanden ist bzw. Produktivdaten auf der/ den Festplatten gespeichert sind!

Nach Installation eines LSI-RAID-Controllers (in meinem Fall ein LSI MegaRAID 9260 4i) verweigerte mir der Controller den Zugriff auf das Webbios (erreichbar während des Boots mit Strg+H, keine RAID-Konfiguration vorhanden). Ein Einrichten der RAID-Konfiguration war mir daher nicht möglich, eine Installation eines Betriebssystems ebenso wenig, da die Festplatten (4x S-ATA 500GB) nur am genannten Controller angeschlossen sind.

Über die Tastenkombination Strg+Y (Achtung, unter Umständen amerikanische Tastaturbelegung, daher dann Strg+Z) erreicht man jedoch das Preboot CLI (CommandLineInterface). Dies bietet ebenso die Möglichkeit, eine RAID-Konfiguration zu erstellen.

Mit dem Befehl

PdList -a0

zeigt das CLI  alle verfügbaren Informationen zu den installierten Festplatten an (Pd = physical Disks). Die Option -a0 beschreibt den ersten installierten Controller, alternativ kann auch die Option -aALL genutzt werden.

Die Ausgabe kann mit dem Druck auf Pause angehalten und mit einer beliebigen Taste fortgesetzt werden.

Mit dem Befehl

CfgLdAdd -r5 [252:0,252:1,252:2,252:3] -a0

wird ein RAID 5 (-r5) erstellt. Dabei werden die vier, direkt (am Controller) angeschlossenen Festplatten genutzt. Dies ergibt sich aus der Angabe [252:0,....]. Intern angeschlossene Festplatten werden als Enclosure 252 angeben an Slot 0 bis Slot 3. Der Controller nutzt somit die vier vorhandenen Festplatten für die Erstellung eines RAID5.

Auch andere Konfigurationen wie RAID0 (-r0) oder RAID1 (-r1) oder RAID10 etc. sind möglich. Bitte greifen Sie dazu auf das Handbuch des Controllers zurück.

Wurde der Befehl der Erstellung des RAID (der “Virtual Disk”) erfolgreich abgeschlossen, stellt der Befehl

LdPdInfo -a0

 die verfügbaren Informationen zur Virtual Disk dar.

Mit

q

beenden Sie das Preboot CLI und der Server startet neu.

Nach der Erstellung des RAID über das Preboot CLI können Sie ab sofort das Webbios über Strg+H erreichen! Eine Ursache dafür ist mir nicht bekannt. Es funktionierte in meinem Fall so mit einem alten HP DL160 G5 und einem LSI MegaRAID 9260 4i.